読者です 読者をやめる 読者になる 読者になる

PerlerのRuby日記

Rubyとか

短いけどわかりにくいコードを可読性考えて書きなおしてみた

Ruby

なんかこういう感じのコードがあったので、

def readable?
  !Hoge.count(self) == 0 && self.title != ""
end

こういう感じに書き換えた。

def readable?
  return false if Hoge.count(self) == 0
  return false if self.title == ""
  true
end

3行に増えたけど、否定演算子を使ってないから、読みやすくなったのではないかと思う。